Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
OpenSim Compile
#1
Hallo ich weiss nicht woran es liegt, ich fang mal an...

Ich habe einen V-server und eine Zotac ID1 PC beide mit Linux

Code:
Description:    Debian GNU/Linux 9.6 (stretch)
Release:        9.5
Codename:       stretch

Wenn ich mir eine Source von von Opensimulator.org hole

dann kann ich diese nicht compilieren
Code:
...
(Build target) ->
/opt/test1/opensim-0.9.0.0-source/ThirdParty/SmartThreadPool/SmartThreadPool.csproj (default targets) ->
/usr/lib/mono/xbuild/14.0/bin/Microsoft.CSharp.targets (CoreCompile target) ->

        CSC: error CS0518: The predefined type `System.Object' is not defined or imported
        CSC: error CS0518: The predefined type `System.ValueType' is not defined or imported
        CSC: error CS0518: The predefined type `System.Attribute' is not defined or imported
        CSC: error CS0518: The predefined type `System.Int32' is not defined or imported
        CSC: error CS0518: The predefined type `System.UInt32' is not defined or imported
        CSC: error CS0518: The predefined type `System.Int64' is not defined or imported
        CSC: error CS0518: The predefined type `System.UInt64' is not defined or imported
        CSC: error CS0518: The predefined type `System.Single' is not defined or imported
        CSC: error CS0518: The predefined type `System.Double' is not defined or imported
        CSC: error CS0518: The predefined type `System.Char' is not defined or imported
        CSC: error CS0518: The predefined type `System.Int16' is not defined or imported
        CSC: error CS0518: The predefined type `System.Decimal' is not defined or imported
        CSC: error CS0518: The predefined type `System.Boolean' is not defined or imported
        CSC: error CS0518: The predefined type `System.SByte' is not defined or imported
        CSC: error CS0518: The predefined type `System.Byte' is not defined or imported
        CSC: error CS0518: The predefined type `System.UInt16' is not defined or imported
        CSC: error CS0518: The predefined type `System.String' is not defined or imported
        CSC: error CS0518: The predefined type `System.Enum' is not defined or imported
        CSC: error CS0518: The predefined type `System.Delegate' is not defined or imported
        CSC: error CS0518: The predefined type `System.MulticastDelegate' is not defined or imported
        CSC: error CS0518: The predefined type `System.Void' is not defined or imported
        CSC: error CS0518: The predefined type `System.Array' is not defined or imported
        CSC: error CS0518: The predefined type `System.Type' is not defined or imported
        CSC: error CS0518: The predefined type `System.Collections.IEnumerator' is not defined or imported
        CSC: error CS0518: The predefined type `System.Collections.IEnumerable' is not defined or imported
        CSC: error CS0518: The predefined type `System.IDisposable' is not defined or imported
        CSC: error CS0518: The predefined type `System.IntPtr' is not defined or imported
        CSC: error CS0518: The predefined type `System.UIntPtr' is not defined or imported
        CSC: error CS0518: The predefined type `System.RuntimeFieldHandle' is not defined or imported
        CSC: error CS0518: The predefined type `System.RuntimeTypeHandle' is not defined or imported
        CSC: error CS0518: The predefined type `System.Exception' is not defined or imported

         1 Warning(s)
         31 Error(s)

wenn ich mit eine Git hole und ich dann eine aktuelle version 0.9.1x bekomme

dann geht es....

Problem ist ich wollte auch versuchen das DTL/NSL Currency Server for OpenSim (v0.9.0)
einzusetze....

Also wenn ich dann also die Anleitung 2 volge diese hier :
Code:
git clone git://opensimulator.org/git/opensim opensim
cd opensim
svn co http://www.nsl.tuis.ac.jp/svn/opensim/opensim.currency/trunk opensim.currency
./runprebuild.sh && xbuild
cd opensim.currency
./build.sh

Ist es nicht möglich das Build für das moneymodul auszuführen.... allso build Fail....

Frage: Creator fehler ??? Linux Version ??? Xbuild version ???
Ich denke auch nicht das es was mit dem Hoster zu zun hat...... da die V-server im im KVM laufen und damit jedes Betriebssystem möglich ist....

Anders gefragt: Gibt es für 0.9x alternative MoneyModule , die unter selbstkontrolle sind ... ich will in erster Linie Basteln, Spielgeld... KEINE Anbieter, die mir module anbieten die dann auf deren System laufen, oder gar selber geld anbieten.... auch nicht einen wo man eine Bankliezenz, Gewerbeschein etc.... braucht.

Es geht hier in erster Linie um Spielgeld(Virtuelle Knöpfe, Steine Muscheln... Wie auch immer...) und um eine Bautelle abseits von SL und Opensim mit Money...:-)





lg
Zitieren
#2
Moin ;D

Kann dir leider in moment nicht helfen, aber ich hab mal deine beiden Threads in das richtige Forum verschoben ;D

Welche Mono Version hast du am laufen ? Hast du die 0.9.0er auch vom Git gezogen ?
Tschöö

Bogus | PinguinsReisen.de
Zitieren
#3
Also unter dem V-Server habe ich

Code:
root@v21223:~# mono -V
Mono JIT compiler version 4.6.2 (Debian 4.6.2.7+dfsg-1)
Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
        TLS:           __thread
        SIGSEGV:       altstack
        Notifications: epoll
        Architecture:  amd64
        Disabled:      none
        Misc:          softdebug
        LLVM:          supported, not enabled.
        GC:            sgen
root@v21223:~#

Zotac PC

Code:
root@zotac1:~# mono -V
Mono JIT compiler version 4.6.2 (Debian 4.6.2.7+dfsg-1)
Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-proj                                                      ect.com
        TLS:           __thread
        SIGSEGV:       altstack
        Notifications: epoll
        Architecture:  amd64
        Disabled:      none
        Misc:          softdebug
        LLVM:          supported, not enabled.
        GC:            sgen
root@zotac1:~#

Ich kann mir vorstrellen das nicht jeder unter Windows X oder Linunx x die Projekte Schreibt....
so kann es sein das ich unter C## version x mein Projekt anders abspeichere als mit c## unter Windoof....
Wie auch immer ist nur ne vermutung warum der hier und da aussteigt....

Wenn etwas unter Windows compiliert ist läuft es dann auch unter Linux ???
nagut ...wenn noch jemand ne Idee hat last es mich wissen.... Fragen sind ja gestellt :-)

zum Thema MoneyModul habe ich noch irgenwas gelesen das da ne alte Struktur beim Compilieren benutzt wird die Deprecated ist... Ich glaube das war im Mantis... Aber ein Fix ist nicht genannt... Undecided



Und ein Danke fürs verschieben...
Zitieren
#4
Keine ahnung obs dir hilft, aber versuch mal die 0.9.0er mal von hier
http://opensimulator.org/dist/

Ob da die Übersetzung klappt, k.a

Soll das Grid nachher eigentlich auch HG haben ?
Tschöö

Bogus | PinguinsReisen.de
Zitieren
#5
Um es gleich vorwegzunehmen, mit dem Money Modul kann ich dir auch nicht helfen. Ich kann es mir mal anschauen, aber ich denke nicht, dass es viel bringt.

Zum kompilieren: was meinst du mit "eine Git hole"? Meinst du den schon seit drei Jahren nicht mehr aktualisierten Quellcode auf Github?

Es gibt vor allem einen Grund: das sind die zusätzlich benötigten Module, die evtl. fehlen. Manchmal passen auch die .NET Versionen nicht. Wenn es mit xbuild nicht geht, versuche ich es mit nant. Mal geht es so, mal anders rum. nant war offiziell lange nicht mehr unterstützt, aber ich habe es erst vor ein paar Monaten erlebt, dass ich nur mit nant kompilieren konnte.

Wenn Git richtig konfiguriert ist, dann sollten eigentlich unterschiedliche Zeilenende im Source Code automatisch richtig gesetzt werden.
Zitieren
#6
Bitte msbuild benutzen.

./runprebuild.sh
msbuild

Ob das Money System so funktioniert davon bin ich nicht überzeugt.
Du must warscheinlich den source des OpenSimulators ändern oder des Money Modul.

Achso: Versuche erstmal nur OpenSim zu kompilieren, dann weiste ob das schon mal geht, bevor du irgend etwas einbaust.
[Bild: attachment.php?aid=2586]


[-] The following 1 user says Thank You to Manfred Aabye for this post:
  • Pius Noel
Zitieren
#7
Aaaaaaaaalso.........
Das mach ich auh gleich mal in einem anderen Threat....

Debian 9 Stretch wird mit einer alten Mono Version mitgeliefert... 4.6 irgenwas.....

Das Compilieren der SimSoftware benötigt eine Aktuellere Version...
Diese Infos habe ich mir aus dem Mantis gelesen......

Ich hab mal mein Mono aktualsiert.... auf 5.1 x

https://www.mono-project.com/download/st...lin-debian

und nun klappte es auch mit dem MoneyModul... DTLNSL....

Nun bastel ich an meinem Projekt erstmal weiter... Die basis Stimmt ... nun Kommt erstmal eine Avatarregistriertung, Passwortänderung, Passwort vergessen PhP scripts....

lg
Zitieren
#8
Danke, Manfred. Ich habe soeben in den Build Instructions gelesen, dass jetzt msbuild empfohlen wird. Cool
[-] The following 1 user says Thank You to Pius Noel for this post:
  • Bogus Curry
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
Brick Neues Grid aka Aufbau OpenSim mit Robust und Co... brenner23 29 660 14.11.2018, 20:47
Letzter Beitrag: brenner23
  OpenSim installation Miss Undercover 9 1.654 10.02.2018, 12:03
Letzter Beitrag: Miss Undercover
  Opensim bei einem externen Hoster Munala Kaliopov 73 15.640 02.12.2017, 12:55
Letzter Beitrag: Leora Jacobus
  Erste Erfahrungen mit OpenSim unter Linux Pharcide 2 1.657 30.05.2017, 16:00
Letzter Beitrag: Pharcide
  Hilfe beim Einrichten des Servers und Opensim Grid Kolke 31 10.791 03.04.2017, 02:04
Letzter Beitrag: Bogus Curry

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste