Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Nix geht mehr mit Win 10
#1
Ein freundliches Hallo erstmal an Alle !!

Nach "gefühlt" 100 Jahren habe ich endlich mal wieder Zeit und Muße mich um Opensim zu kümmern.
Damals hat mir das Tuto von Dorena SEHR geholfen um mich auch im Hypergrid frei bewegen zu können.
Doch heute ?!

Es hat sich verdammt viel getan seit damals.

Wo soll ich anfangen ;-)
Also (alter) neuer PC mit Windows 10 Version 1909 (Build 18363.418), daran die Fritz!Box 7362 SL.
Alte (neue) Fritz!Box mit der ich auch schon damals gearbeitet habe ;-)

Wie gesagt - damals war alles besser :-) - nein, damals lief alles rund bei mir.
Opensim mit MySQL, und allem was eben dazu gehört.
Die ganzen benötigten Ports offen die OS haben wollte.
3 eigene Regionen auf meinem PC und alle erreichbar übers Hypergrid -
b.z.w auf dem kleinen privaten Server auf meinem PC hatte jedermann Zugriff.
Manchmal haben wir uns auf den Regionen mit sechs Mann (Frauen) getummelt.

Alles super eingestellt - auch wie erwähnt Dank Dorenas super Tuto und Hilfe.

Ich (Wir) hatten Spass ohne Ende.
Und heute?

Seit Windoof 10 und diesem Sch.... IPV6 klappt einfach nix mehr.
Ich habe sowohl die neue (aktuelle) Version von OS (von opensimulator.org) als auch verschiedene andere Distros ausprobiert.
U.a. die von outworldz.com
Auf letztere hatte ich meine ganze Hoffnung gesetzt - da ja wohl alles von alleine eingestellt wird.
Was nicht der Fall war ;-(

Naja - jetzt sitze ich also (fast) Tag für Tag an meinem PC und experimentiere mit OS und den wohl ganz neuen Einstellungsmethoden
Und nix will mir gelingen.
Immer und immer wieder tauchen neue Fehler auf.

Zusammengefasst:
Fritz!Box 7362 SL alle Ports offen die ich brauche.
Win-Firewall alle Ports offen die ich brauche.
Freies Antivirus gelöscht und Defender am laufen.
Gruppenrichtlinien geändert - sprich Netzwerkeinstellungen u.s.w. und wieder in den original Zustand versetzt.
DynDns bei verschiedenen Anbietern ausprobiert - nix. (Meldung an der Fritz: temporär deaktiviert)

Fritz!Box läuft mit DS-Light-Tunnel.
Alle mir bekannten (und im Netz gefundenen) Einstellungsmöglichkeiten ausprobiert.

Keine meiner Versuche bringt mich weiter.
Schalte ich IPV6 aus - geht garnix mehr - auch kein Internet.
Liegt es an IPV6?
Liegt es an meiner Unwissenheit?
Liegt es allgemein an Windoof 10?

Ich verzweifele ;-)

Kann mir eventuell jemand aus meiner Misere helfen?
Ich würde doch so gerne wieder Teil der OS-Family sein - b.z.w. so gerne wieder im Hypergrid unterwegs sein ;-(

Achja - noch was anderes.
Habe im OSGrid einen Account (auch schon Jahrelang) und wollte mich da mit Phönix einloggen.
Fehlermeldung: No Inventory Folder found - Anmeldung geht nicht ;-(

Die Grids wollen mich alle nicht mehr ;-( ----- ;-)

HILFE !! ;-)
Zitieren
#2
Ich hab deinen Text zwar nur quergelesen, aber die Antwort ist offensichtlich:
Es liegt an IPV6 Exclamation
OpenSim funktioniert nur mit IPV4 - wenn dein Provider dir nur IPV6 bietet bist du in den A... gekniffen.
Sorry
Wer nicht weiss wohin er will, der kommt leicht woanders hin.
[-] The following 2 users say Thank You to Anachron for this post:
  • Cayoun Daydreamer, heimlicher
Zitieren
#3
Hallo Heimlicher, ich werde mal im Laufe des Wochenendes mit meinem WIN-10 Lapi schauen ob ich da was hinbekomme und den Weg dahin hier posten. Inworld bin ich ja meistens über meinen Desktop-Rechner und de läuft eben unter Linux. Ansonsten stimme ich Anachron zu. Frage mal deinen Provider, wie es bei denen mit IPV4 Adressen aussieht.
[-] The following 1 user says Thank You to Dorena Verne for this post:
  • heimlicher
Zitieren
#4
Hi Heimlicher,

von diesem Problem habe ich schon von Arbeitskollegen gehört.
Vielleicht hilft Dir dieses Video weiter.
https://www.youtube.com/watch?v=ttEHsjjvRS4&t=407s
Dies setzt aber ein Server ausserhalb Deines Netzwerkes voraus.

Bei Oracle Cloud bekommst Du auf Lebzeiten über Free Tier (also kostenlos), eine VM, die zwar klein ist, aber für ein VPN und einem Reverse Proxy zu Deinem heimischen Netzwerk durchaus ausreicht.

Vielleicht ist das die Lösung für Dein Problem ?

Viele Grüße
Pharcide
Grüsse, Pharcide
[-] The following 1 user says Thank You to Pharcide for this post:
  • heimlicher
Zitieren
#5
Hallo Heimlicher,

leider muss ich die bisherigen Antworten bestätigen, ich habe nämlich auch DS-Light. Damit ist es zwar möglich, IPv4 Adressen zu erreichen (sonst würde auch der OpenSim-Viewer nicht gehen), aber selber ist der eigene Rechner von außen nur über IPv6 erreichbar. Folglich gibt es nur drei Optionen:
1) Preiswerten V-Server in einem Rechenzentrum mieten, da gibt es meistens eine IPv4 dazu (sicherheitshalber vorher informieren). Das ist meine Lösung.
2) Einen IPv6 Tunnel aufbauen zu einem Server, der eine IPv4 Adresse hat (*). Das habe ich experimentell mal gemacht, denn ich betreibe Freifunk-Gateways. An den Routern unserer Community gibt es IPv4 und IPv6, dank Tunnel - hier aus Haftungsgründen - geht das auch hinter meinem DS-Light. Es wäre natürlich extrem unhöflich, fremde Gateways mit dem Traffic eines Online-Spiels zu belasten. Wenn du nicht sowieso einen Server für andere Zwecke schon hast, könntest du besser gleich Variante 1 wählen statt extra was zu mieten.
3) Deinen Provider überreden, dir doch ausnahmsweise eine echte IPv4 Adresse zu geben.

Liebe Grüße,
Mareta

(*) = Ich empfehle das moderne Protokoll "Wireguard". Erstens ist das performanter als OpenVPN, und zweitens braucht man nur von einem Ende des Tunnels die IP-Adresse wissen. Die IPv6 des Servers kann fest konfiguriert werden, während die Internetprovider bei Privatkunden meistens die IPv6 Adressen dauernd ändern, um eben Serverbetrieb möglichst zu erschweren. (Off topic: Offiziell wechseln die Provider natürlich, um ihre Kunden vor Ausspähung ihrer IP-Adressen zu schützen. Da aber alle IPv6 Adressen eines Kunden diesem exklusiv zugeteilt werden, kann man das mit ein wenig Mathe eindeutig zuordnen.)
Hyperweb.eu => Server-Tutorial für Linux mit OpenSim.
[-] The following 2 users say Thank You to Mareta Dagostino for this post:
  • Anachron, heimlicher
Zitieren
#6
Hallo.
Ersteinmal vielen lieben Dank für Eure schnellen Antworten.

Natürlich habe ich mich vorher schlau gemacht (lesen bildet ja bekanntlich) und alle möglichen Szenarien durchgespielt.
Meine Hoffnung aber war, daß es jemandem schon gelungen ist dieses leidige Thema IPV6 zu lösen.
Aber es scheint wirklich so - daß es ohne einen externen Server keine andere Möglichkeit gibt.
Mein Provider stellt sich stur was IPV4 angeht, und die einzige Antwort war:
Man kann IPV6 in der Fritz komplett abstellen.
Aber wie und welchen Einstellungen es bedarf - keine Info. Die Dame im Servicecenter war ungehalten ;-)

@Anachron
Der schnellste ;-) -- Danke.

@Dorena
Das wäre SUPER wenn du da irgendetwas hinbekommen würdest.
Aber ich denke ohne externen Server geht es wirklich nicht.

@Pharcide
Danke. Natürlich hilft das Video - man lernt ja nie aus.
Und was Neues ist ja immer gut fürs Brain ;-)

@Mareta Dagostino
Vielen Dank. Aber wie Du schon erwähnst - und auch die anderen bezeugen - gibt es wohl für mich keinen anderen Weg als Extern zu gehen ;-(

An alle liebe Grüße und schönes WE.
Werde wohl erst Anfang der Woche wieder on sein.
[-] The following 1 user says Thank You to heimlicher for this post:
  • Anachron
Zitieren
#7
Nochmal kurz ...
bevor das WE kommt ;-)

Was ist eigentlich mit sogenannten Tunnel-Brokern?
Da mein Englisch nur auf Schulenglisch reduziert ist - verstehe ich manche Dinge nicht so richtig.
Und die "tollen" Übersetzer geben dann nur Kauderwelch wieder.

Wäre das eine Möglichkeit - so ein Tunnelbroker?
Oder ist da was "gefährliches" dran?
Klappt das?
hat jemand Erfahrung damit?

Jetzt bin ich weg - - - schönes WE euch allen
Zitieren
#8
(26.10.2019, 13:18)heimlicher schrieb: > Was ist eigentlich mit sogenannten Tunnel-Brokern?

Tunnelbroker sind im Prinzip Gateways, damit geht es. Falls du einen findest, der gratis oder (verglichen mit einem V-Server) preiswert hinreichende Datenrate und Latenz hat, wäre das ein Weg: IPv4 über OpenVPN oder Wireguard auf eine von denen (dynamisch!) vergebene IPv4 Adresse, dahinter irgendein DynDNS Dienst, und hoffen dass die Verbindungsqualität für den Betrieb einer Region noch reicht.

Um 10 TB/Monat Traffic tausender Fremder von einem meiner Freifunk-Gateways anonym ins Internet zu leiten, habe ich OpenVPN von Mullvad am Start. Das kostet aber 5€ pro Monat und damit etwa genausoviel wie die zweitkleinste VM von Hetzner. Von der kleinsten Hetzner VM für 3€ rate ich für OpenSim ab, da wird der Arbeitsspeicher schnell eng.

EDIT: Was außerdem für Rechenzentren spricht, ist die erheblich bessere Datenrate bei der Internet-Anbindung. Gerade der Upload ist z.B. bei meinem Vertrag zu Hause kümmerlich (2 Mbit/sek). Was für die Besucher Download von Texturen usw. ist, das ist aus Sicht des Regionenservers Upload. Im Rechenzentrum mit 1 Gbit/sek ist auch bei mehreren Besuchern das Nadelöhr jedenfalls nicht die eigene Internetanbindung, sondern je nachdem die Rechenleistung des V-Servers oder die Internetanbindung der Besucher. Falls zu Hause ein Rechner extra wegen OpenSim ganztägig durch läuft, sind alleine die Stromkosten höher als die Miete einer kleineren VM.

Auch dir ein schönes Wochenende! Smile
Mareta
Hyperweb.eu => Server-Tutorial für Linux mit OpenSim.
[-] The following 2 users say Thank You to Mareta Dagostino for this post:
  • Anachron, heimlicher
Zitieren
#9
Sooooooooo......
nach langem Hin und Her habe ich festgestellt (auch Dank Eurer Hinweise) daß es mit dem DS-Lite wirklich nicht funktioniert.
Ich habe dann richtig Druck gemacht bei meinem Provider - mehrere Anrufe, mehrere Emails, mehrere Posts im Provider eigenen Forum) - und siehe daaaaa von Heute auf Morgen hatte ich richtigen DualStack. Big Grin

Und was soll ich Euch sagen...nun klappt es auch wieder mit OS Heart
Allerdings habe ich (vor Jahren mal auf meiner FP gespeichert) nur eine o.7..er am laufen.
Es funzt alles - und habe auch schon wieder viele Reisen ins HG gemacht.
U.a. auch nach Dorenas World. Schöne Welt übrigens Dorena!!!!

Frage:
Wenn ich jetzt die aktuelle Version (o.9...) nehmen möchte - was und wo muss ich was eintragen?

In der 0.7... wußte ich noch genau was und wo ich was einstellen musste.
In der 0.9... blick ich irgendwie nicht durch Huh
Könntet ihr mir da vielleicht Tips geben?

Übrigens habe ich xampp als Server laufen und alles schön in der MySql gespeichert.
Bräuchte also quasi nur umstellen auf die neue Version.

Dazu noch ein Hinweis und eine Frage:
Wie gesagt unter Xampp läuft die alte 0.7..er ohne Murren und Knurren.
Aber mit dem Versuch die Diva 0.9... mit Wifi zu starten ging nichts mehr.
Braucht die Diva in Xampp andere Einstellungen?

Viele Fragen - ich weiß.
Aber ich bin auch nicht mehr der Jüngste Angel und obwohl ich sehr viel Suche und Lese - es will dann doch nicht alles so funktionieren wie ich gerne möchte.
Mein Ziel ist es, einen Grid aufzusetzen um ein "vollwertiges Mitglied" der OS-Gemeinde zu werden.
Vorerst aber nur im Kleinen - wie gesagt alles auf meinem Rechner - um dann irgendwann mal einen externen Server zu mieten, und Euch dazu einzuladen.
Mein Hobby und meine Leidenschaft ist die Musik.
Und als DJ war ich in SL bekannt - mit eigener Sim - (je Sendung ca. 25 Zuhörer) und auch meine damalige kleine Welt auf meinem PC war gut besucht ;-)
Und genau da will ich auch wieder hin. Nicht nach SL sondern in Opensim.

Es wäre also sehr nett wenn Ihr mir mit Eurem Wissen weiter helfen könntet.

Vielen Dank schonmal.
[-] The following 1 user says Thank You to heimlicher for this post:
  • Dorena Verne
Zitieren
#10
So mal zum Testen hätte ich was, da kannst du auch die Inis als Beispiel verwenden.Wink
Einmal hier: "Arriba on Stick" wird "OpenSim on Stick"

Oder hier: Aus "Arriba Minigrid" wird "OpenSim Minigrid"
[-] The following 1 user says Thank You to Dorena Verne for this post:
  • heimlicher
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Wifi geht nur teilweise Pharcide 8 1.814 05.01.2019, 17:49
Letzter Beitrag: Dorena Verne

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste