Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Blender 2.80 und die Neue Umgebung
#1
Huhu

Ich denke mal ich fange mal an, Unter Linux ist es nicht zu empfehlen die Einstellungen beim ersten Start aus der 2.79 zu uebernehmen, es scheint erstmal zu funktionieren, aber schon nach dem Speichern und dem Versuch einen
Neustart von Blender zu machen, laeuft das ins Leere, es startet nicht mehr. also die Confirg wieder loeschen. Gilt zumindest fuer Xubuntu 18.04.2 LTS, wie andere Linuxversis damit umgehen weiss ich nicht.

Wer nicht weiss wo die Ist, Home verzeichnis, eigener Name und dann versteckte Ordner sichtbar machen, in der .config findet ihr dann unter dem Verzeichnis Blender alle Configurationsdateien 2.78 2.79 und 2.80, nach dem Loeschen startet es wieder.

Aber jetzt erstmal an die die schon Laenger mit der 2.8 arbeiten, sind die Grundfunktionen noch da, denn bei DAE export findet sich kein Export fuer SL/OS mehr, hoffe das das auch ohne geht. Und was mich jetzt erstmal stoert wieder alles neu lernen wo es sich versteckt, warum nur muss man bei jeder x.x0 Version alles neu lernen, das ist etwas nervig so kommt man nie 100% mit einem Programm klar, zumindest bei der Groesse die es mittlerweile hat.

Amsonsten sieht es ja mal ganz interessant aus. Mal sehen wie sich das jetzt benutzen laesst, wenn einer schon einige Tricks rausgefunden hat wo welche Sachen jetzt sind, wuerde ich mich und sicher einige andere auch, sehr drueber freuen, wenn einer was postet. ich darf jetzt erstmal alles rausfindenWink

lg
Ezry
Nichts im Leben ist ein Muss!!!!!!!!!!!..............Alles ein Kann!!!

http://angels-world.nl:8002:Angels-Place 01
[-] The following 2 users say Thank You to Ezry Aldrin for this post:
  • Dorena Verne, Pius Noel
Zitieren
#2
Zuerst mal danke für den Hinweis mit den Konfigs. Für mich ist es jetzt auch zuerst mal gewöhnungsbedürftig. Ich bin mal gespannt, was mir 2.8 insgesamt bringt.

"Export to SL / Opensim" ist unter dem Reiter "Arm" (für Armature) immer noch vorhanden, einfach etwas versteckt.

LG Pius
[-] The following 1 user says Thank You to Pius Noel for this post:
  • Ezry Aldrin
Zitieren
#3
Huhu

Thx, ich habe schon gedacht ich bin nur etwas doof, und wollte erst garnicht schreiben, aber
Scheine ja doch ab und an helfen zu koennen.

Wer hat denn schon mal neuerer Sachen probiert, die vieleicht vorher komplizierter waren zu lösen, gab ja immer einiges was kompliziert ist, als in den 100erte Eure Teuren 3D Programmen

Bastel mich da immo ganz langsam durch, aber gibt sicher Sachen die ich nicht kenne, aber doch sehr nützlich sind, finde zum Beispiel nicht die Funktion, das wieder auf Metrisch zu stellen, und wo ist die Umstellmoeglichkeit geblieben auf GLSL damit man in der Scene auch die Texturen beim Bauen sieht.

Lg
Ezry
Nichts im Leben ist ein Muss!!!!!!!!!!!..............Alles ein Kann!!!

http://angels-world.nl:8002:Angels-Place 01
Zitieren
#4
Moin,
im ersten Bild sieht man die Metric Einstellungen.

Um die Textur zu sehen, musst Du, wie im zweiten Bild, im Node-Editor ein Material drauflegen und
dann oben rechts umschalten, um die Textur zu sehen.
Zum Bauen im Layout-Fenster auch oben umschalten, damit die Textur sichtbar wird.
Ansonsten kann ich das Blender Handbuch sehr empfehlen: https://blender-handbuch.de/handbuch.html
oder auch diese Seite, wo fast täglich neue kleine Tutorials und Tipps veröffentlicht werden: https://www.blendernation.com/


Angehängte Dateien Bild(er)
       
Wer nicht vom Weg abkommt, bleibt auf der Strecke !!!

dorenas-world.de:8002:Siwa
[-] The following 3 users say Thank You to Jason Oak for this post:
  • Bogus Curry, Ezry Aldrin, Pius Noel
Zitieren
#5
Hallo zuammen ;D

Also ich muss sagen, mir kommt die neue Oberfläche sehr entgegen ;D Hab sogar - fast - alleine rausgefunden wie man auf einen anderen Weg, als den Jason her erklärt, eine Textur auf ein Objekt legen kann ;D Damit hatte ich in den vorigenden Versionen immer meine Probleme.

geholfen hat mir dieses Video
https://youtu.be/fZSD7pVIUkY

Ist wohl in englisch, aber ist die Bilder sagen einiges aus ;D

Ach und ich hab mein Oberfläche fast ganz in deutsch übersetzt, wobei die Übersetzung noch in Arbeit ist. Dazu bastelt ich natürlich unter Linux *gg Irgendwie mag ich da lieber mit Blender basteln ;D
Tschöö

Bogus | PinguinsReisen.de
Zitieren
#6
Huhu,

Ich glaub man versteht mich da etwas falsch, ich habe das in 2.79 So eingestellt, das man im Editor also dem 3DView die Texturen die ja nun einmal schon alle gemappt und aufgelegt sind, sehen kann, und neue Objekte hinzufuegen kann, die dann ebend noch texturiert werden muessen, ich habe nicht vor meine 5 Jahre Arbeit neu zu UV-mappen und neu zu texturieren, das ist schlicht ein Ding der Unmoeglichkeit. es sind richtig genommen schon7 bis 8 Jahre, fertig wird man ja nie, und die Texturen sind auch alle da, nur ich seh sie nicht im 3DView ich seh nur die Materialien, und will die Textur sehenWink

In Blender 2.79 starte ich eine Scene, dann sind alle texturen da. Das liess sich ueber das GLSL im Shadingfenster wunderbar einstellen, Umgewoehnen ist eine Sache, wollte jetzt aber nicht Stunden, oder Monate damit verbringen erstmal alles wieder rauszusuchen denn so komme ich einfach mit der Sim nicht weiter, bisher ist das Handbuch zur 2.8 nicht sehr hilfreich.

Ich hoffe nun war es verstaendlicher was ich suche, denn eine uebernahme der 2.7 einstellungen fuehrt nunmal zum Crash der 2.8

lg
Ezry

Nachtrag: Die GLSL Einstellung habe ich gefunden unter Preferences / Viewport, ganz unten einstellbar, aber texturen nicht sichtbar weiterhin, auch bei einem Test das neu zu machen nicht, irgendwo hakt es. Wenn ich nur wuesste wo, aber nu ist erstmal FeierabendWink
Nichts im Leben ist ein Muss!!!!!!!!!!!..............Alles ein Kann!!!

http://angels-world.nl:8002:Angels-Place 01
Zitieren
#7
Hallo Ezry,

ich denke ich konnte dein Problem nachstellen. Aber leider gehen bei mir auch die Texturen verloren. Wenn ich ein .blend File mit 0.79 abspeichere und dann mit 0.8 lade, sind den Meshes die neuen "Node" Shader zugeordnet (Principled BDSF), ohne dass irgendwas am "Base Color" Slot angehängt ist. Die Node Shader wurden zwar bereits in der 0.79 eingeführt, aber bisher hatte ich auch mit klassischen Texturen gearbeitet. Vielleicht kommt ja demnächst irgendwer mit einem Importer um die Ecke.

Glücklicherweise hatte ich bisher ja nur die Meshes exportiert und die Texturen inworld in OpenSim aufgeklebt, so dass die Texturen in Blender nur temporäre Hilfsmittel fürs UV-Mapping waren. Da ich mit Albedo, Normals und Specular arbeite, und Collada nur Albedo exportieren kann (selbst das scheint in der 0.79 kaputt zu sein?), hatte ich den Texturen in Blender bisher wenig Aufmerksamkeit gezollt.

Zur Ehrenrettung von Blender muss ich aber sagen, dass sie jetzt viel näher am Industriestandard sind als vorher. Dies betrifft halt nicht nur die Bedienung, sondern auch die Datenformate...

Mein nächstes Blender-Experiment werde ich mit dem neuen Open Source Format glTF 2.0 machen, dem Nachfolger von Collada und ebenfalls von der Khronos Group entwickelt. Da sind große Firmen mit im Boot wie Microsoft, Unity, Google, Adobe, NVidia, Oculus. In glTF 2.0 kann man ganze Szenen exportieren einschließlich Materialien. Sowohl Unity als auch die OpenSource Engine Godot können das einlesen.

Liebe Grüße,
Mareta
Hyperweb.eu => Server-Tutorial für Linux mit OpenSim.
Zitieren
#8
Huhu,

Ich denke mal ich konnte das Problem loesen, zumindest scheint es so, aber es ist leider ein Stueck Arbeit,
doof bei grossen Scenen.

Wenn die Scene geladen ist, kann man ja auch das Material Panel und das Texture Panel sehen. im Texturepanel steht aber irgendwie nichts, also nicht wie ich jetzt gestern nacht um 3 Uhr, einen grossen Schreck bekommenWink Das ist nicht schlimm.

Wenn man die ganze Scene Collection sehen kann in der 3Dview(Userperspektive), das kann man daran sehen das unter UserPerspektive dann Scene Collection mit noch einige Informationen, steht, in meinem Fall steht dort jetzt z.b. (4)Scene Collection | Cube.016
hat man die Moeglichkeit ein einzelnes Object, jetzt mit Linksklick, nicht mehr mit Rechtsklick, auszuloesen.

Danach macht man einem Linksklick, ja wir muessen uns umstellenBig Grin , auf der Standardarbeitsflaeche , im Feld Surface auf Use Nodes, damit wird das Feld Base Color, aber auch die anderen Felder freigegeben.

Gesperrt Kleiner Punkt frei kleiner Kreis, Dann ein Linksklick auf den Kreis den ihr nun sehen solltet.

Daraufhin oeffnet sich ein Fenster mit mehreren Auwahlmoeglichkeiten , ihr klickt jetzt auf Image Texture, wieder mit linksklick, danach steht in den Menu darunter so ein Berg mit nem Punkt im Kasten daneben +New und daneben ein abgebildeter Ordner mit dem Wort Open.

Da nun drauf klicken und Voilla ihr koennt eine Neue Texture auswaeheln. In alten Scenen sind die Texturen ja eingebaut, wenn man immer brav Pack into Blender File in der 2.79 benutzt hat, klickt auf den Feil neben dem Icon mit dem Kegel(berg) und dem Punkt , dort sind dann alle Texturen vorhanden, allerdings, mit einer 0 davor, wie wir aus vorherigen Versionen wissen, heisst das, das die Texturen 0 Materialien zugeordnet sind, und zwar alle.

Jetzt waehlt ihr die Textur die auf dieses Object gehoert, und in der 3DView(Userperspektive) sieht man die Textur, wunderlicherweise korreckt auf dem Object. Mich wundert es, das man nicht auch die ganzen UVMaps neu machen muss, aber das kann vieleicht ein anderer erklaeren, habe 2.8 erst seit 2 Tagen.

Ich denke mal ich habe es einigermassen beschreiben koennen, da ich keine Bilder gemacht mit Makirerungen.

lg
Ezry
Nichts im Leben ist ein Muss!!!!!!!!!!!..............Alles ein Kann!!!

http://angels-world.nl:8002:Angels-Place 01
[-] The following 1 user says Thank You to Ezry Aldrin for this post:
  • Pius Noel
Zitieren
#9
Huhu

@Mareta, das Problem in OS wird aber bleiben, dieser Nachfolger von Collada wird so sicher nicht nutzbar werden, gibt es da etwa schon eine Moeglichkeit das in OS reinzubekommen, denn immer 1000de Teile hochzuladen, kostet neben Nerven eine verdammt grosse Menge verlorener Zeit. Der Versuch mal eine Ganze Scene inkl texturen und allem hochzuladen, bringt jeden Viewer in die Knie, und den Rechner zum CrashWink)

lg
Ezry
Nichts im Leben ist ein Muss!!!!!!!!!!!..............Alles ein Kann!!!

http://angels-world.nl:8002:Angels-Place 01
Zitieren
#10
Ich konnte es auch nachvollziehen und sehe das ähnlich wie Mareta. Für ein einfaches Objekt, konnte ich das Problem wie folgt lösen:

1. In Blender 2.8 eine Kopie des .blend-Files das mit Blender 2.79b erstellt wurde öffnen.
2. Objekt erscheint ohne Farbe. Das Layout entspricht dem, wie die Datei in 2.79b gespeichert wurde.
3. Beim Viewport "solid" auswählen.
4. Bei den Viewport-Einstellungen Shading vom "Material" auf "Texture" ändern.
5. Im Material-Menu unter Surface "Use Nodes" anklicken. Es erscheint Surface "Principled BSDF".
6. Das kleine Kreislein bei "Base Color" anklicken und "Image Texture" auswählen.
7. Jetzt kann die Textur, die zum Default UV-Mapping passt, gewählt werden.

Um zu zeigen, was ich gemacht habe, habe ich ein kleines Video erstellt: https://youtu.be/Rbb5cU74E9k
Es ist mein erstes YouTube (hust, hust, hust...)

Pius

Nachtrag: in der Zwischenzeit hat sich hier einiges getan. Ich lasse meinen Beitrag und mein Filmchen trotzdem mal stehen.
[-] The following 2 users say Thank You to Pius Noel for this post:
  • Bogus Curry, Ezry Aldrin
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Blender 2.80 erschienen [Stand: 31.07.19] Bogus Curry 17 13.467 31.07.2019, 12:50
Letzter Beitrag: Bogus Curry
  Blender-Handbuch.de - Blender zum selbst erlernen [16.03.19] Bogus Curry 8 7.066 16.03.2019, 21:55
Letzter Beitrag: Bogus Curry
  Workflow: Blender-Mesh mit Textur erstellen Bogus Curry 2 581 11.02.2019, 22:00
Letzter Beitrag: Bogus Curry
  Blender 2.8 Kurs für Anfänger Jason Oak 6 1.234 16.12.2018, 20:28
Letzter Beitrag: Pius Noel
  Blender 2.8 beta [Stand: 01.12.18] Bogus Curry 0 807 01.12.2018, 22:21
Letzter Beitrag: Bogus Curry

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste