Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Von Mono 5.x auf 6.x upgraden
#1
Hallo zusammen ;D

Aktuell ist ja die Mono 6.4.x, aber unter meinen Linux Mint 18.3 läuft immer noch die 5.1.x, Mit einfachen update command kommt man da nicht weiter, da kommt die Meldung das es aktuell wäre. Nun die Frage wie upgrade ich von der 5.1 auf die aktuelle 6.x ?
Tschöö

Bogus | PinguinsReisen.de
Zitieren
#2
Schon getestet? Eigendlich für Ubuntu, könnte aber auch bei Mint klappen:
Code:
sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF
sudo apt install apt-transport-https ca-certificates
echo "deb https://download.mono-project.com/repo/ubuntu stable-xenial main" | sudo tee /etc/apt/sources.list.d/mono-official-stable.list
sudo apt update
[-] The following 1 user says Thank You to Dorena Verne for this post:
  • Bogus Curry
Zitieren
#3
Jup, das ist das was ich immer mache, nur hat das nichts gebracht, da danach immer halt die Meldung kommt, das die Version aktuell sei ;D
Tschöö

Bogus | PinguinsReisen.de
Zitieren
#4
Eventuell mal mono vorher komplett entfernt?
Code:
Sudo apt-get purge mono-runtime  
Sudo apt-get purge mono-complete  
Sudo apt-get purge libmono* libgdiplus cli-common libglitz-glx1 libglitz1
[-] The following 1 user says Thank You to Dorena Verne for this post:
  • Bogus Curry
Zitieren
#5
Ich hab nun Mono 5.x untergeschmissen, wenn ich nun mono-compete installieren will, kommt dieses hier

Code:
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
mono-complete : Hängt ab von: mono-runtime (= 6.4.0.198-0xamarin3+ubuntu1804b1) soll aber nicht installiert werden
                 Hängt ab von: mono-runtime-sgen (= 6.4.0.198-0xamarin3+ubuntu1804b1) soll aber nicht installiert werden
                 Hängt ab von: mono-llvm-support (= 6.4.0.198-0xamarin3+ubuntu1804b1) soll aber nicht installiert werden
                 Hängt ab von: libmono-2.0-1 (= 6.4.0.198-0xamarin3+ubuntu1804b1) soll aber nicht installiert werden
                 Hängt ab von: mono-utils (= 6.4.0.198-0xamarin3+ubuntu1804b1) soll aber nicht installiert werden
                 Hängt ab von: mono-devel (= 6.4.0.198-0xamarin3+ubuntu1804b1) soll aber nicht installiert werden
                 Hängt ab von: mono-mcs (= 6.4.0.198-0xamarin3+ubuntu1804b1) soll aber nicht installiert werden
                 Hängt ab von: mono-roslyn (= 6.4.0.198-0xamarin3+ubuntu1804b1) soll aber nicht installiert werden
                 Hängt ab von: mono-csharp-shell (= 6.4.0.198-0xamarin3+ubuntu1804b1) soll aber nicht installiert werden
                 Hängt ab von: mono-4.0-gac (= 6.4.0.198-0xamarin3+ubuntu1804b1) soll aber nicht installiert werden
                 Hängt ab von: mono-4.0-service (= 6.4.0.198-0xamarin3+ubuntu1804b1) soll aber nicht installiert werden
                 Hängt ab von: monodoc-base (= 6.4.0.198-0xamarin3+ubuntu1804b1) soll aber nicht installiert werden
                 Hängt ab von: monodoc-manual (= 6.4.0.198-0xamarin3+ubuntu1804b1) soll aber nicht installiert werden
                 Hängt ab von: libmono-cil-dev (= 6.4.0.198-0xamarin3+ubuntu1804b1) soll aber nicht installiert werden
                 Hängt ab von: referenceassemblies-pcl soll aber nicht installiert werden
                 Hängt ab von: msbuild soll aber nicht installiert werden
                 Hängt ab von: ca-certificates-mono (= 6.4.0.198-0xamarin3+ubuntu1804b1) soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
Tschöö

Bogus | PinguinsReisen.de
Zitieren
#6
Na ok, werde mal das machen was ich eigentlich eh vor hatte. Werde mal Ubuntu Budgie 19.10 installieren ;D Denke da wird die 6er dann leichter zu installieren sein. Die Dist wollte ich testen, backups vom Home mache ich grade ;D

Falls aber jemand trotzdem ne Lösung für das obere Problem hat, der kann sie gerne posten. Könnte für andere User dann nützlich sein, die dasselbe Problem vielleicht haben ;D
Tschöö

Bogus | PinguinsReisen.de
Zitieren
#7
Sowas ist leider ziemlich blöd, ich habe das Problem gerade mit OpenSUSE 15.1. Das ist auch ein Grund, warum mein Tutorial bezüglich dieser Version noch so schattig ist. Jetzt habe ich zwar erfolgreich mit Handeingriffen Mono 5.20 installieren können statt 5.10 im Original, aber für die Allgemeinheit ist manuelles Auflösen der Paketabhängigkeiten auch mit Yast-Unterstützung keine Freude. (Ich werde es demnächst trotzdem online bringen, aber mit dem Verweis, doch möglichst besser Ubuntu zu nehmen oder auf die 15.2 zu warten...)

Wenn Xamarin kein passendes Paket für die jeweilige Distribution zusammenstellt, muss das halt irgendwer anders tun. Tut dies in der verwendeten Distribution niemand, ist ein Upgrade eines derart komplexen Einzelpakets ein großer Krampf. Oft funktioniert ja die Strategie, Pakete einer "ähnlichen" Distribution zu nehmen, aber leider eben nicht immer.
Hyperweb.eu => Server-Tutorial für Linux mit OpenSim.
[-] The following 1 user says Thank You to Mareta Dagostino for this post:
  • Dorena Verne
Zitieren
#8
Leider habe ich zurzeit kein Mint installiert, um das ganze mal durchzuspielen.Undecided
Zitieren
#9
Ist denn in der Ubuntu 19.04 die 6er von mono in den reps vorhanden ? Vielleicht werde ich da mal näher nachschaun, das wäre dann ja ne alternative, jedenfalls für den localen PC. Auf den Server wird ja meist die 18.04 von Ubuntu ja genommen ;D

Aber da die meisten ja eh unter Windows ihr OpenSim installiert haben, ist das Problem ja nicht so akut, denke ich mal ;D
Tschöö

Bogus | PinguinsReisen.de
Zitieren
#10
Ubuntu 19.04 habe ich nicht, aber auf 18.04 läuft das Mono-Upgrade problemlos. Ubuntu ist ja eine der direkt von Xamarin unterstützten Distributionen (neben Debian, Centos, Fedora und Raspbian). Ubuntu 19.04 und auch 19.10 enthalten Mono 5.18, das wäre immerhin hinreichend für OpenSim 0.9.1.
https://www.mono-project.com/download/st...wnload-lin
https://packages.ubuntu.com/search?keywo...o-complete
Hyperweb.eu => Server-Tutorial für Linux mit OpenSim.
[-] The following 1 user says Thank You to Mareta Dagostino for this post:
  • Bogus Curry
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Upgrade Erfahrungen OpenSim 0.9.1, Mono 5.x unter Linux: Data Rossini 12 2.371 12.02.2019, 13:16
Letzter Beitrag: Pius Noel
  Welche Version von Mono? DJ Luka 21 11.598 05.03.2017, 13:58
Letzter Beitrag: Manfred Aabye
  Qnap NAS seit FW upgrade MONO Fehler Dasti 3 4.007 04.06.2016, 14:14
Letzter Beitrag: Dasti
  Welche Version von Mono ist OpenSim tauglich ? Bogus Curry 10 7.796 30.03.2016, 20:09
Letzter Beitrag: Mareta Dagostino
  Mono 4.2.1.102 besser auslassen da geht gar nichts Bogus Curry 1 1.933 18.11.2015, 00:09
Letzter Beitrag: Bogus Curry

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste