Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
"Sammelthread" Probleme mit der 0.9.1.0 snail
#1
Ich mache mal den Anfang:
1. Langsames rezzen der Region.
Scheinbar fehlen Prims, die nach einem Relog wieder da sind.
Das mit den "fehlenden" Prims tritt massiv mit dem Firestorm auf.
Der CoolVL-Viewer rezzt, wenn auch leicht verzögert, ohne relog alles nach.

2. Visitor-Board zeigt nichts mehr an.
Zitieren
#2
Einem Problem, das mit Besucher-Boards aufgetreten war, konnte ich auf den Grund gehen:

Mit der Version 0.9.1.1, Nov 4th 2019 wurde die OSSL-Funktion osSetDynamicTextureDataBlendFace um einen Parameter erweitert. Dabei ist offenbar auch einige andere Verhaltensweisen der Funktion überarbeitet worden, sodass diese sich nun weniger "fehlertolerant" verhält.

In dem Script des offenbar weit verbreiteten Anzeige-Boards war dem Parameter alpha der Wert FALSE zugeordnet worden, jedoch ist hier ein Bytevalue (also 0-255) und kein Boolscher-Operator (TRUE oder FALSE) gefordert.
FALSE wird nun aber em Wert 0 zugeordnet, und daher ist die erzeugte Textur nicht wie beabsichtigt opaque sondern volltransparent!
Nach Ersetzen des fehlerhaften Wertes FALSE mit dem richtigen Wert 255 ist die korrekte Funktion des Boards wiederhergestellt.

Da ich vermute, dass dieser Scriptfehler sich im Laufe der Zeit auch in andere Anzeigeobjekte "durchgewurmt" hat, dürfte er nunmehr auch bei anderen Scripten, die auf dem fehlerhaften Code basieren auftreten. Ich hoffe hiermit einen Beitrag zur Fehlersuche und Reparatur bei entsprechenden Objekten gegeben zu haben.
Wer nicht weiss wohin er will, der kommt leicht woanders hin.
[-] The following 4 users say Thank You to Anachron for this post:
  • Bogus Curry, Dorena Verne, Klarabella Karamell, Sylvia Koeln
Zitieren
#3
Da misch ich mich mal mit ein - obwohl ich ja immer noch Anfänger bin Blush
Ich weiß jetzt nicht ob es die Snail ist (was auch immer das bedeutet), aber die runtergeladene von OS.org
spinnt genauso.
Ich hab sie am laufen als StandaloneHypergrid (hier auch ein paar Fragen dazu), und ich finde gegenüber den anderen Versionen läuft sie bei mir (Win10) sehr gut.
Doch wie Dorena sagt und ich stimme zu:

Fehlen nach ein paar Logins die Prims - - nicht alle aber ein paar schon.
Hab dann - mal aus reiner Vorsicht oder wie auch immer - eine neue OAR hochgeladen.
Beim ersten Login war alles da.
Beim zweiten Login fehlten ca. 10 Dinge, beim dritten Login sogar fast über die Hälfte aller Sachen.
Hab den Firestorm und den Cool ausprobiert - bei beiden das gleiche.

Ist natürlich blöd Big Grin
Zitieren
#4
(14.11.2019, 18:08)heimlicher schrieb: Da misch ich mich mal mit ein - obwohl ich ja immer noch Anfänger bin Blush
Ich weiß jetzt nicht ob es die Snail ist (was auch immer das bedeutet), aber die runtergeladene von OS.org
spinnt genauso.
Ich hab sie am laufen als StandaloneHypergrid (hier auch ein paar Fragen dazu), und ich finde gegenüber den anderen Versionen läuft sie bei mir (Win10) sehr gut.
Doch wie Dorena sagt und ich stimme zu:

Fehlen nach ein paar Logins die Prims - - nicht alle aber ein paar schon.
Hab dann - mal aus reiner Vorsicht oder wie auch immer - eine neue OAR hochgeladen.
Beim ersten Login war alles da.
Beim zweiten Login fehlten ca. 10 Dinge, beim dritten Login sogar fast über die Hälfte aller Sachen.
Hab den Firestorm und den Cool ausprobiert - bei beiden das gleiche.

Ist natürlich blöd Big Grin

Also "Snail", genauer "OpenSim 0.9.1.0 Snail Release" ist der offizielle Name des 0.9.1er Release ...
Wenn du deine 0.9.1 von OS.org runtergeladen hast, wirst du also sicher auch so ein Schneckchen haben. Big Grin

Das mit den fehlenden Prims: Wirklich weg sind sie ja nicht, aber aus unerfindlichen Gründen zeigt der Viewer sie nicht an. Es sind auch nicht immer die gleichen Prims, die fehlen.

Im Gegensatz zu dir habe ich den Effekt aber auch nur beim Firestorm beobachtet, nicht beim Cool VL. Auch hatte ich eher den Eindruck, dass es mit der Zeit weniger wird, nicht mehr, aber da will ich mich nicht so weit aus dem fenster lehnen - Murphy hört alles ...Rolleyes
Wer nicht weiss wohin er will, der kommt leicht woanders hin.
Zitieren
#5
So, nachdem ich grade noch (s.o.) die Berichte über fehlende Prims bestätigt habe, habe ich gerade mal meinen Firestorm durch unser Grid rauf- und runtergeprügelt und die Probleme scheinen wie durch Zauberhand verschwunden zu sein.
Da Grid-Mama Dorena ja an meiner Seite sitzt, weiss ich dass sie nichts unternommen hat, worauf man diese Verbesserung zurückführen könnte. Es ist also einfach so passiert!
Meine Theorie ist, dass es eine Weile gedauert hat, bis sich die Asset-Caches der Regionen ordentlich gefüllt hatten. Man sollte also der neuen Version 1-2 Tage Zeit lassen sich einzulaufen, ehe man ihre Performance beurteilt.

Nach meiner Tour-de-Force bin ich eigentlich euphorisch: Die SIM Übergänge sind butterweich und wenn man dem Viewer die Zeit lässt auch das letzte Asset abzurufen ist auch alles da. Auch hatte ich nicht den Eindruck als ob das Snail-Release seinem Namen allzuviel Ehre zollt. Es dauert zwar etwas, bis sich die Objekte aufbauen, aber keineswegs langsamer als wir das von der Arriba kannten.
Wer nicht weiss wohin er will, der kommt leicht woanders hin.
[-] The following 2 users say Thank You to Anachron for this post:
  • Bogus Curry, Dorena Verne
Zitieren
#6
Dinge die aus anderen Grids kopiert werden landen beim rezzen im Heimatgrid in der Luft, wie mir eben mitgeteilt wurde. Aber eben nicht grundsätzlich je nach Herkunftsgrid mal ja, mal nicht.
Kennt das noch jemand?
Zitieren
#7
Das mit em "in die Luft rezzen" hatte ich vorher auch schon öfter - deshalb hab ich es als es wieder passiert ist nicht als "neues Problem" gesehen. Vor der Umstellung rezzten oft Dinge gar nicht an der Stelle an der sie sollten sondern tauchten auf meiner Nachbarsim auf.

Dafür habe ich das Phänomen, dass ich ein Objekt beim ersten Einloggen an einer Stelle sehe an der es nie gerezzt war (z.B. Haifischfänger auf meinem Friedhof) - das verschwindet aber wenn ich an einen anderen Ort teleportiere und dann wieder zurückkomme.

Und - ein Clone-Script funktioniert nicht mehr - das was in Tanzstangen eingebaut ist (oder im Grabkreuz auf HalloWien und auf meinem Friedhof) - es kommt die Script-Meldung:

OSSL Permission Error: osConsoleCommand disabled in region configuration(script: ** Npc Control ** event: listen primID:c79f407a-c464-42d8-835e-d5d5fbc3e996 at <241.3168, 208.067, 23.02938>)

Ist für mich aber nicht so tragisch, individuelle NPC-Notecards kann ich noch mit einem anderen Tool erstellen wenn es sein soll.
Zitieren
#8
(20.11.2019, 16:29)Rubeus Helgerud schrieb: ...
Und - ein Clone-Script funktioniert nicht mehr - das was in Tanzstangen eingebaut ist (oder im Grabkreuz auf HalloWien und auf meinem Friedhof) - es kommt die Script-Meldung:

OSSL Permission Error: osConsoleCommand disabled in region configuration(script: ** Npc Control ** event: listen primID:c79f407a-c464-42d8-835e-d5d5fbc3e996 at <241.3168, 208.067, 23.02938>)

Ist für mich aber nicht so tragisch, individuelle NPC-Notecards kann ich noch mit einem anderen Tool erstellen wenn es sein soll.

Die Funktion osConsoleCommand ist leider eine sehr gefährliche Kiste, weswegen man sie der Allgemeinheit nicht anvertrauen kann. Würden wir diese öffnen, könnten böswillige Scripte eine Menge Unheil anrichten.
Ich habe mir das Script mal angesehen, wofür es diese Funktion verwendet. Es will damit beim Clonen eines Avatars ein Rebake erzwingen. In aller Regel dürfte dies unnötig sein und ich schlage vor die Zeilen 185-187 abzukommentieren, dann dürfte alles wieder funktionieren.
Wer nicht weiss wohin er will, der kommt leicht woanders hin.
[-] The following 2 users say Thank You to Anachron for this post:
  • Dorena Verne, Rubeus Helgerud
Zitieren
#9
Es funktioniert - clont sogar noch schneller als vorher. Habs gleich mal geändert..
Zitieren
#10
(21.11.2019, 13:17)Rubeus Helgerud schrieb: Es funktioniert - clont sogar noch schneller als vorher. Habs gleich mal geändert..

Klar ist das auch schneller, denn da das Rebake ausgelassen wird, entfallen auch die 20 Sekunden Wartezeit anschließend, damit das Rebake dann hoffentlich durch ist.
Ich gehe einfach davon aus, dass man sich von selbst nochmal mit dem Kamm durch die Haare geht, bevor man sich am Bahnhof in den Fotofix setztBig Grin
Wer nicht weiss wohin er will, der kommt leicht woanders hin.
[-] The following 2 users say Thank You to Anachron for this post:
  • Dorena Verne, Rubeus Helgerud
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Probleme bei der Auswahl der Lieblingsorte im Profil Dorena Verne 2 1.030 11.02.2020, 15:04
Letzter Beitrag: Dorena Verne
  Probleme nach Umstellung von Root Server auf Heim PC Slow 11 3.116 12.11.2019, 14:02
Letzter Beitrag: Slow
  Win10, Update auf offizelle OS 9.01 Version/Config-Probleme Cosmic 22 7.328 19.01.2019, 10:51
Letzter Beitrag: Cosmic
  Teleport Probleme Wollex Baily2 15 16.551 24.07.2017, 14:33
Letzter Beitrag: Rubeus Helgerud
  Was nun, habe Probleme weil IPV6: GELOEST Ezry Aldrin 6 5.412 29.03.2017, 09:44
Letzter Beitrag: Mareta Dagostino

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste